Node 2i Digital output reported as 24 Bit

Comments

25 comments

  • Official comment
    Avatar
    Tony W. - Product Support Manager

    Bluesound Players do not upsample or downsample - check your connections. If the problem persists, please select Help, Send Support Request in the App so we may take a closer look.

    Comment actions Permalink
  • Avatar
    Seppi Evans

    You don’t say what your playing or the DAC you are using but the Node’s digital outputs just pass the stream with no processing, for MQA tracks you can toggle if your DAC supports MQA and pass these unadulterated also.

     

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    Sorry should have been more specific.

    I only use FLAC.

    Sample rate is always displayed correct.

    Both 16 and 24 bit material is reported as 24 bit. My DAC supports MQA but I don't have MQA material, so I have not enabled "external MQA DAC".

    The CD/DAC is a Luxman D-03X.

    I tried converting some 16 Bit FLAC to 32 Bit Wav and the node still reports 24 Bits to the DAC, the DAC's relays did click to indicate Sample or Bit rate change, so this seems more and more like a BS bug.

    0
    Comment actions Permalink
  • Avatar
    Seppi Evans

    Please do try with enabling “external MQA DAC”

    Edit: if you have another device such as a DVD player handy it would be a good test to see what shows when you play a audio CD on it to the Luxman.

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    MQA does not change anything.

    DVD player!!!, what is that, what century are you from, just kidding :) ... had the same thought but I don't own any of that stuff anymore. I tried my TV and it report 48KHz 16Bit so something is going on with the Node 2i.

    0
    Comment actions Permalink
  • Avatar
    Seppi Evans

    Says the man with a CD player, much older tech than DVD 😂

    Best wait for input from a Bluesound rep. I only use the analogue outputs and DACs long gone on eBay.

     

    0
    Comment actions Permalink
  • Avatar
    Sam R.

    The NODE doesn't do any up/downdampling. 

    What's your setup -- ie what is feeding into the NODE, what is the source, what is further along down the chain (make/model). I'm also curious to know if Radio Paradise or TuneIn also always display only 24 bit.

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    Synology DS214 NAS to Node 2i via SMB, downstream the Node is connected via Coax my Luxman D-03X CD/DAC. I have also tried Toslink instead of Coax, but that doesn't change anything.

    Radio Paradise shows 44.1Khz 24Bit, and the MQA Indicator is on.

    Radio TuneIn shows 44.1Khz 24Bit

    The CD/DAC clicks when it changes Sample and bit rates, and playing albums in true 44.1Khz 24Bit does trick the clicking, so I guess everything is bitperfect but something is wrong with the datastream info the Node 2i is sending downstream.

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Sam R.

    Now that's bizarre! At the very least TuneIn should be 16/44.1.

    Small chance this will fix it, but in the BluOS app go to Settings > Player > Audio > Audio Clock Trim and turn this off. You'll need to reboot your NODE (and it may help to reboot your D-03X as well) then test TuneIn again.

    If after that, you're still getting 24 bit on all occasions, please send our support crew a diagnostic log (Help > Send Support Request) so they may check what the log is reporting as the sample rate.

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    I did not help, so I submitted a support request, will update when I have some news.

    0
    Comment actions Permalink
  • Avatar
    Seppi Evans

    It might be worthwhile firing off an email to Luxman just in case they are aware.

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    Already did that, first response from the distributor was that they were not aware of any issues but they would check with Luxman, the response from Luxman is that they only show the data presented in the signal from the source (Node 2i).

    So far the only issue I have is with the Node 2i, so can't really blame Luxman at the moment :) 

     

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    Thanks Tony, already did that, the support crew is looking at the log files.

    1
    Comment actions Permalink
  • Avatar
    Brian Evans

    Rasmus - I'm now experiencing this as well - RME ADI2 DAC showing 24 bit depth for 16 bit content.  Amazon HD, USB Stick flac files... and not passing a bit test.  Did you ever find resolution?

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    Hi,

     

    No solution yet, I'm trying to get Luxman to look into the problem, but they keep insisting that the Luxman DAC only report what its told by the Node 2i.

    Have you found a solution?

    0
    Comment actions Permalink
  • Avatar
    Maurice

    Hi

    Exact same issue.

     

    I have a vault 2i connected to a Luxman D-03x via coaxial cable.  Anything that comes from the bluesound,  whether from its internal hardrive or through Tidal is 24bit according to my D-03x. All my music on the vault 2i is 16 bit.

     

    I have tried choosing different options for Connect to external Dac and Audio clock trim. No difference.  Still shows 24 bit. 

    I have other sources connected to my D-03x and everything displays correctly. 

    Another interesting thing is this is happening with roon also. So if play a file through Roon, to vault 2i the signal path on Roon shows 16 bit, but my D-03x shows 24 bit.

    Additionally I have unplugged both the D-03x and the vault 2i from their power and the 24 bit on the D-03x display remains.

     

    I have a melco, and a few raspberry pi's and they show the correct bits on D-03x. 

     

     any tips would be appreciated 

    0
    Comment actions Permalink
  • Avatar
    Brian Evans

    Rasmus, Maurice,

     

    Ok so I WAS actually able to resolve this issue.  I hate to say it... but I completely forget what it was that did the trick. 

    I'm pretty sure I performed a factory reset.

    At the very least I used "Reset All" in Settings/Audio

    Node is now correctly reporting bit depth and passes bitcheck... and sounds great!

    Good luck hope this does the trick for ya'll also! 

    Factory Reset instructions here:

    WARNING!

    THIS IS A FACTORY RESET OF YOUR PLAYER. ALL CUSTOMIZATION INCLUDING WI-FI NETWORK CONFIGURATION, FILE SHARES, AND SAVED PLAYLISTS WILL BE LOST. YOU WILL HAVE TO RE-CREATE THESE ONCE THE FACTORY RESET IS COMPLETE. THIS PROCESS IS ONLY RECOMMENDED IF YOUR PLAYER IS NOT FUNCTIONING AND AN INTERNET FIRMWARE UPGRADE HAS FAILED. FOR ANY QUESTIONS OR CONCERNS CONTACT AN AUTHORISED BLUESOUND CUSTOMER REPRESENTATIVE BEFORE PROCEEDING.

     

    For factory reset instructions of previous generations or other Bluesound products, refer – Gen1 Bluesound Players, PULSE SUB+, PULSE SOUNDBAR in the help center.

    Before proceeding with the factory reset, backup playlists. For more information, click here.

    To factory reset the Bluesound Players, perform the following steps:

    1. Disconnect the player from the electrical power outlet and wait for 30 seconds.
      (Disconnect the battery pack (BP100) as well for the PULSE FLEX)
    2. Reconnect the player to the electrical power outlet.
    3. Once the status indicator LED turns Red, pressa) and hold the PLAY/PAUSE button. The LED immediately turns Green and then Red. Continue holding* the PLAY/PAUSE button for 30 seconds.
    4. After 30 seconds, the LED blinks Red – then release the button.

    All customization to Bluesound Player is removed and restored to factory settings. 

    Note: The music stored in the internal hard drive of VAULT is not deleted.

    The factory reset is successful when the player:

    • Wireless connection – Returns to Hotspot mode (LED turns solid Green)
    • Wired connection – Connects as a new player (LED turns solid Blue)

    *IMPORTANT - Releasing the PLAY/PAUSE  button before the LED blinks Red, cancels the factory reset, and freezes the player in Upgrade Mode. You should restart the procedure to factory reset the player.

    0
    Comment actions Permalink
  • Avatar
    Maurice

    Thanks I will check that after work

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    I did a factory reset recently, and it did not fix the problem, and absolutely no luck with Luxman support.

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    Just tried adjusting and resetting the music settings, still no luck :-(

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    Att Brian,

    Please provide you setup, Coax/Toslink, and what music settings you are using, it makes no sense that everything is okay with your Luxman and ours ain't working.

     

    I took a look at the log and here is what's going on:

    Jan 19 21:03:43 (none) user.info ./ms.pl: Controller::_Codec_play Controller.pm (1413) 2760
    Jan 19 21:03:43 (none) user.info ./ms.pl: FileCodec::init FileCodec.pm (115) flac -F --decode --silent --stdout --force-raw-format --endian=little --sign=signed -- 02 - Decoration Day.flac
    Jan 19 21:03:43 (none) user.info dspout: Stream: id=13 44100/16/2 replay-gain:0 version:0x6
    Jan 19 21:03:43 (none) user.info dspout: Playback device is default
    Jan 19 21:03:43 (none) user.info dspout: Stream parameters are 44100Hz, S16_LE, 2 channels

    The stream parameters, which I assume is the info_stream to the Luxman player is correct, so the error seems to be on the Luxman side, or a bug in the format delivered by the Bluesound.

    0
    Comment actions Permalink
  • Avatar
    Brian Evans

    Rasmus,

    My Node (v3) is feeding an RME-ADI2DAC via Coax. 

    Tone control:  Off

    Sub: Off

    Replay Gain: Disabled

    Output: Stereo

    MQA DAC - Off

    Output Level Fixed - On

    Audio Clock Trim - On

    Wish I could help more but I forget which change did the trick and fixed the bit depth error.  I tried toggling all the settings, firmware update, factory reset.  Somewhere in there it started reporting the bit depth correctly!

    Good luck hope it works for you too!

    0
    Comment actions Permalink
  • Avatar
    Maurice

    So no luck for me. I tried the factory reset.

    Rasmus, I think we're out on a boat with this.  Brian has the Rme. 

    Thanks for the help Brian 

     

    0
    Comment actions Permalink
  • Avatar
    Rasmus

    Hi Maurice,

    I agree :-(.

    Do you have any other players or streamers that works with the Luxman. I have a Sonos but it upsamples everything to 24Bit, so it does not work for testing, and my LG TV only outputs 16bit. I have lots of USB streamers, but the Luxman does not show bit depth when using USB, only on coax and spdif.

    BTW: Thanks for the help Brian :-)

     

    0
    Comment actions Permalink
  • Avatar
    Maurice

    Hi I moved on from the D-03x.....sorry,I'm afraid I won't have anything to contribute past this point

     

    0
    Comment actions Permalink

Please sign in to leave a comment.