issues connecting nad t758v3 to wifi




  • Official comment
    Sam R.

    Hello Tom, 

    The hotspot should appear once you do the Factory Reset, and will show up as IP Address "" under the System Info of your T758v3. 

    However if it does not, it may be faster to use an Ethernet connection temporarily so you may fill in your WiFi details. I will have steps below:

    1) Disconnect the power from your T758

    2) Connect an Ethernet cable directly to the receiver, which goes directly to your router

    3) Connect the power back into the receiver

    4) Wait until the T758 powers up

    5) Open the mobile BluOS controller while connected to the WiFi network of your home

    6) Select the 3 lines in the top left corner of the BluOS app and go to Settings

    7) Select Player and then WiFi

    8) Select the WiFi network you wish to connect to and enter the password for it

    9) Wait 5 minutes and then disconnect the power from your T758

    10) Disconnect the Ethernet cable and then reconnect the power 


    Sam R.


    Comment actions Permalink
  • Avatar
    Tom Vandermaesen

    First of all the receiver doesnt have an ethernet port.

    The nad receiver who is reported with stickers to be a legit bluos player, has a usb hub with a bluetooth and wifi adapter attached to it.

    You say connect to that ip address. But this will never work if im not connected to the hotspot. And i just did the complete factory reset succesfully ( all my settings are gone ) and i was waiting with my phone next to it to see its wifi hot spot. Nothing....

    I can open up the bluos controller app on android but this will never work if the NADis not connected to the wifi....

    So im lost here.. and very sad.... 

    You will mostlikely send me to nad support now ...

    Comment actions Permalink
  • Avatar
    Augustin Safdi

    Hi, I have the same problem with the NAD T758 V3 Bluos kit.
    Everytime i have to disconnect the power and back.
    Then it sees the player again, and then it drops again.
    Router settings are as they should.
    Still got no answer from the support team.
    I read alot of the same issues about it.
    It has always worked perfectly for 2 years and now i cant use it anymore like this.
    So i will wait a little more for a solusion.

    Comment actions Permalink

Please sign in to leave a comment.