NAD 368. Trouble with the network connection after update

Answered

Comments

31 comments

  • Official comment
    Avatar
    Tony W. - Product Support Manager

    *** UPDATED OFFICIAL COMMENT ***

    Hello All

    Thank you for your continued patience.

    We are in the process of releasing BluOS 3.8.8 and you should see it as a prompt in your player within the next 24 hours. It will also be available on the NAD C368, C388, M12 and M32 product pages within the next 48 hours.

    If you have Factory Reset your system, you have made matters worse by erasing any network configuration. That being said, the issue is only affecting the wired network adapter low-level firmware. If you connect your player wirelessly using the wireless adapter included in your packaging, the BluOS MDC will work fine. The USB Extension Cable included in your package also doubles as a wireless antenna to help increase network throughput.

    If you have not set up your player wirelessly, please visit www.bluesound.com/setup to follow the easy instructions.

    Finally - you will need to be connected to the network to install the update until the product pages downloads are updated - our support crew at support@bluos.net will be happy to assist.

    Thank you for your patience and understanding.

    Comment actions Permalink
  • Avatar
    Steve Rae

    Good morning Luis.
    I suffered the same outcome when I update to 3.8.3. Only solution was to reinstall previous version (3.6.12) which I had stored on usb stick. Everything works fine after this. If you do not have a copy of this software I could e mail it to you if you wish.
    Regards
    Steve.

    0
    Comment actions Permalink
  • Avatar
    Luis

    Hi Steve,

     

    it would be very kind of you. I'm getting crazy with this issue, it's been two weeks without being able to use my C368 like it should be used.

     

    Thanks in advance,

     

    Luis

    0
    Comment actions Permalink
  • Avatar
    Steve Rae

    No worries Luis. I will send it over later today. Let me know how you get on and if you need any help with installing it.
    Steve.

    0
    Comment actions Permalink
  • Avatar
    Luis

    Hi Steve,

     

    I would really appreciate that. I'll wait for your e-mail and get back to you when hopefully everything is fixed.

     

    Luis

    0
    Comment actions Permalink
  • Avatar
    Steve Rae

    Hi Luis

    Just sent you an email. Let me know how it goes. Good luck.

    Steve

    0
    Comment actions Permalink
  • Avatar
    Rob Wijnstok

    Hi Steve, I have the exact same problems as Luis has. I have a NAD C388 with a BluOS MDC. After the last update, very hard to connect. Mostly of the time it fails to connect. Could you please sent me the previous firmware/update aswell?

    Thanks in advance.
    Rob, Netherlands

    0
    Comment actions Permalink
  • Avatar
    Steve Rae

    Hi Rob.
    Email sent to you with update. Let me know how you get on.
    Kind regards
    Steve .

    0
    Comment actions Permalink
  • Avatar
    Luis

    Hi all,

    After trying several times, it worked! 

    Thank you all so much for your help.
     
    @Bluesound, please let us know when you fix a new (properly working) update.
     
    Luis, from Barcelona Spain.
    0
    Comment actions Permalink
  • Avatar
    Luis

    Hi all,

    What you should do in case you're facing the same trouble I had with the new firmware update (3.8.3) is:

    1. Download the previous Firmware version 3.6.12 on a blank USB Stick (thanks Steve for sending me the file, and @Bluesound, please update older firmware versions in your website so that we can access them).

    2. Make sure you do not connect via Ethernet or wireless when you apply the software.

    3. With the C368/C388 powered OFF, connect the USB mass storage device (containing .img file
    already) to any of MDC BluOS module’s two USB input ports. Do not connect the USB mass
    storage device to the SERVICE port.

    4. Switch ON the unit and then press the front panel Standby button to switch the unit from standby
    to operating mode.

    5. Select “BluOS” source.

    6. Press [d] repeatedly until “Source Setup” is highlighted. Press [s] twice to go to “BluOS Setup”
    menu.

    7. From “BluOS Setup Menu”, select the following:

    a Service Menu
    b Under “Service Menu”, there are two options - BluOS Upgrade or BluOS Service. Select “BluOS
    Upgrade”.
    c Under “BluOS Upgrade”, there are two options – “Yes” or “No”.
    d Select “Yes” to start BluOS Upgrade.


    8. BluOS upgrade process will automatically start. The progress of the upgrade process can be
    monitored in the BluOS Controller app as well as in the front panel display.

    9. Then check the software version through the BluOS screen on the NAD unit to check version shown is 3.6.12.

    10. Reboot your C368 by unplugging the power cord. Let it be like this for 1 min.

    11. Plug again your Ethernet Cable.

    12. Once you resume an internet connection you are asked if you want the update and I answered “no” so retaining the version 3.6.12

    0
    Comment actions Permalink
  • Avatar
    Lex Majoor

    I've also got these issues. With my nad m10. Could someone here please provide me with the img file? A lot of thanks! Regards!

    0
    Comment actions Permalink
  • Avatar
    Steve Rae

    Hi Lex
    If you post your email I will send you a message with a link to the software version 3.6.12. Follow the above instructions and all should work.
    Kind regards
    Steve.

    0
    Comment actions Permalink
  • Avatar
    Lex Majoor

    Thanks Steve!  

    Regards,

    Lex

    0
    Comment actions Permalink
  • Avatar
    Steve Rae

    Hi Lex.
    Just sent email to you. Let me know how it goes. Good luck.
    Steve.

    0
    Comment actions Permalink
  • Avatar
    Lex Majoor

    Yep! just downloaded the stuff. Will let you people know how it went. And thanks a lot Steve!

     

    regards,

    lex

    0
    Comment actions Permalink
  • Avatar
    Rob Wijnstok

    Hi all, so far no update. My system stays in "executing BluOS Upgrade" for a very long time. It doesn't change. So after step 8. nothing happens. Is it possible that three .img is confusing for the NAD? Should it be just one .img file?

    0
    Comment actions Permalink
  • Avatar
    Steve Rae

    Hi Rob.
    The three img files are all required for the update. Not sure what is causing the issue. I note you are updating a NAD C388 unit whilst the software was for a NAD C368. Not sure if this makes a difference? Otherwise I would attempt a reboot of the MDC module & retry the above steps ensuring no Ethernet or WiFi connection before inserting usb. It’s a shame nobody from Bluesound appears to be contributing with help or advice.
    Regards
    Steve.

    0
    Comment actions Permalink
  • Steve - it makes a difference

    Rob - just connect your player wirelessly as I suggest under the official comment.

    Thank you

    0
    Comment actions Permalink
  • Avatar
    Steve Rae

    Hi all,
    Just seen update above from a Tony W from Bluesound . It does seem they are trying to find a solution so hopefully won’t be too long before this issue is resolved. Thanks.
    Steve

    1
    Comment actions Permalink
  • BluOS 3.8.8 is being rolled out to resolve this issue now. Please see the updated official comment.

    0
    Comment actions Permalink
  • Avatar
    Luis

    Hi Tony,

    Thanks for the update. I already see the pop-up with the new update.

    Anybody tried the 3.8.8? I would like to double check that works fine for someone with a NAD C368 to avoid the bad experience with the previous update... I don't want to spend another 2 weeks without my player working correctly.

    Thanks in advance,

     

    Luis

    0
    Comment actions Permalink
  • Avatar
    Rob Wijnstok

    Hi all, good news. My NAD C388 works fine again with the BluOS 3.8.8 update. Can't be a coincident, nice update number ;-)
    Everyone thanks a lot, for the given help.

    Rob

    0
    Comment actions Permalink
  • Our Pleasure Rob

    The number is a complete coincidence... We are sorry for the initial inconvenience and the undue delay in getting your music to you... perhaps when you need it the most...

    0
    Comment actions Permalink
  • Avatar
    Steve Rae

    Hi all.
    I have successfully installed update 3.8.8 on my NAD 368 with BluOS MDC2i and am pleased to report it installed smoothly & all functions appear to run correctly. Thank you Bluesound for the update.
    Kind regards
    Steve.

    0
    Comment actions Permalink
  • Avatar
    D Flynn

    I have the NAD 368 with BluOS and had the problem with the previous update.  After frustration - I moved my router to close to the NAD368 and got it working over WIFI.  

    Does anyone know how to switch back to hard wired?  I am assuming that I would run a BluOS reset, maybe turn the power off on the back, then hard wire ethernet, and turn on.  Thoughts?  Tips?

    0
    Comment actions Permalink
  • Avatar
    Wesley P.

    Hello D. Flynn,

    The Ethernet connection of your C368 will take priority over the WiFi connection. To connect your C368 back over Ethernet, simply reconnect the Ethernet cable to the back of your C368. This also means if the Ethernet is disconnected in the future, it will revert to your WiFi instead of remaining in its hotspot mode.

    You can verify if your C368 is using Ethernet or WiFi by going to Help > Send Support Request through the BluOS app and if you do not see any entry for Signal Strength, it is connected over Ethernet.

    Regards,
    Wesley P.

    0
    Comment actions Permalink
  • Avatar
    D Flynn

    Wesley P.

    Thank you - I was nervous to mess up and lose music right now.

    I  went into 'Help' on the  BlueOS App, then chose 'Diagnostics'.  It showed the wifi.  I then turned off the amp, plugged in the ethernet cable - checked Diagnostics again and it was connected.  Easy.

    Your assistance is much appreciated!!  Back to very fast responses on the amp.

    0
    Comment actions Permalink
  • Avatar
    Lex Majoor

    FYI. The upgrade solved the same problem on my m10.

    0
    Comment actions Permalink
  • Avatar
    Patrick Pol

    Is this version also applicable to the NAD-390DD? The NAD product page still shows the malfunctioning firmware 3.8.3 and my bluos app does not show a new firmware popup.

    NAD Product page: https://nadelectronics.com/product/c-390-dd-direct-digital-powered-dac-amplifier/

     

    0
    Comment actions Permalink
  • Avatar
    Wesley P.

    Hello Patrick,

    Due to logistic issues caused by our transition to work from home since the recent COVID-19 outbreak, we have been unable to update the firmware available through the NAD and Bluesound webpages.

    With that being said, please open the BluOS app and go to Help > Check for Upgrade - Player to receive the latest firmware through the BluOS app.

    If you continue to experience issues or are still unable to get this update, please contact our support crew directly at support@bluesound.com for further assistance.

    Regards,
    Wesley P.

    0
    Comment actions Permalink

Please sign in to leave a comment.