Dolby surround to work on N330+N150?

Answered

Comments

3 comments

  • Official comment

    Hi Jori

    Sounds like your HDMI splitter does not support ARC and would require a full HDMI extractor that supports ARC, which usually would run you into the $200US/€220 range...

    If you can run optical from the source to the front POWERNODE, you should receive DOLBY - you may have to set the source to PCM. If you need further troubleshooting, drop us a note by selecting Help, Send Support Request in the BluOS App along with the makes and model numbers of your external gear and our Support Crew can assist further.

    Comment actions Permalink
  • Avatar
    kadajawi

    What you can try is use a HDMI extractor that has an optical output. Those start at around 20 Euro, though I have had bad experiences using such a model with an Audiolab amp. The POWERNODE wasn't too happy either, though it fared better IIRC. Maybe bad luck, maybe typical of cheap HDMI extractors. I did switch to a better model which works fine.

    Basically you'd go from the source via HDMI into the extractor, and then via HDMI into the projector. The optical out of the extractor goes into the POWERNODE. This is the setup that I am using (it works for surround too), as the HDMI ARC of my TV does not let through anything but PCM 2.0.

    0
    Comment actions Permalink
  • Avatar
    Jori Koskinen

    Yeah, thanks! Actually that's what I did after trying 2 different hdmi splitters without an optical output. Bought a cheapest one from Amazon with the toslink, and now it's working with 5.1 sounds. Great!

    0
    Comment actions Permalink

Please sign in to leave a comment.