node 2 firmware upgrade stalled

Answered

Comments

9 comments

  • Official comment
    Avatar
    Sam R.

    Hello there, 

    I have escalated your case; a member of our support crew will be in touch. 

    Regards,
    Sam R.

    Comment actions Permalink
  • Avatar
    Neutrikxlr

    I have the exact same issue

    0
    Comment actions Permalink
  • Avatar
    Sam R.

    You're case has been escalated. 

    Regards,
    Sam R.

    0
    Comment actions Permalink
  • Avatar
    Pknowq

    Super common problem if you search the forums there's lots of people reporting the same. If you tried the reset and usb loading the firmware and that didn't work, it's bricked and you have to hope your dealer or BS replace it. I have 13 node and power mode 2s and frequently have this problem frequently. For the last couple of years, the dealer has taken it back returned it to Bluesound and is been fixed and returned.....albeit usually a 3-6 month turnaround time. The most recent one I've been told is not fixable and they've suggested I get a 2i.
    I'm a big fan of BS and much prefer it to Sonos primarily for the MQA, but I would never buy it without a good warranty or dealer back due to the software updates issue.
    Btw..I had lots of excuses over the years, it's because I'm on WiFi, the connection is poor, the connection is lost... Over that time I ended up hard wiring them all, increasing my internet bandwidth, and monitoring my connection through every update.... didn't make any difference. I've spent so many hours trying various fixes. I don't think my dealer even bothers trying the usb update and stuff anymore, just seems it back to them. In fact I just came on the forum now to see if there was a BS3 coming out as I have another Node2 bricked and don't want to get the 2i if the 3 is on its way

    0
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    Hi Pknowq

    We will be in touch as I have escalated your current issue to our support crew.

    0
    Comment actions Permalink
  • Avatar
    M de Jager

    I have the same issue now, since Wednesday. Turned red all of a sudden. None of the fixes work - incl. the USB firmware suggestion. Please help out.

    0
    Comment actions Permalink
  • Avatar
    Sam R.

    Looks like you've opened a support request manually (by sending an email to support@blueound.com); a member of the support crew will be in touch. 

    0
    Comment actions Permalink
  • Avatar
    M de Jager

    Just got word back it is related to HW issue and need to contact my dealer. Curious what will happen next.

    0
    Comment actions Permalink
  • Avatar
    Pknowq

    Good luck!  My dealer had arranged a few to be swapped over the years with Bluesound.

    Unfortunately, not this time round.  It bricked in January, because of lockdowns dealer couldn't take it until May.  Then in November, I was told that it can't be effectively repaired.  I did get 30% off a new 2i (couldn't get back the defective one). 

    Clearly, there is something fundamentally wrong with the hardware and Bluesound must be fully aware of it.  Not once did their solution of updating the software via USB work.  Their ineffective proposed solutions cost me countless wasted hours!!

    I'm hoping the 2i doesn't have the same problems!

     

    0
    Comment actions Permalink

Please sign in to leave a comment.