Permission Denied in Big Sur

Answered

Comments

19 comments

  • Official comment
    Avatar
    Tony W. - Product Support Manager

    Hi All

    We have replicated the issue here in our offices. The issue appears to be an Apple issue and not related directly to Bluesound. Apple has made changes to the SMB protocol or what is often commonly known as Windows File Sharing or SAMBA. There are messages about this in a number of macOS sources.

    Please contact Apple for an update or possible fix for this. 

    Thanks for your patience and understanding.

    Comment actions Permalink
  • Avatar
    BeansMalloy

    I upgraded to Big Sir two day ago and can confirm, experiencing the same issues. I submitted my issues through the app yesterday.

    Edit: I'm running BluOS 3.12.6 and I just upgraded to the latest MacOS App 3.12.1 which fixed the problem. Will update if that changes.

    Edit2: The updated to 3.12.1 did not fix this issue. 4-5hrs later, permission has been denied once again.

    0
    Comment actions Permalink
  • Avatar
    Eric

    You gave me hope but same here, the issue remains. Faster to reboot my Mac then reindex my library but still annoying. Admin, would be great to know when the fix will come! Thanks.

    1
    Comment actions Permalink
  • Avatar
    Sam R.

    Hello all,

    We're having difficulty replicating this, so if you haven't already, please send a diagnostics log to our support crew (via Help > Send Support Request, log will be automatically attached) and, if you are using a NAS, the make/model of that NAS.

    In the meantime, you may potentially need to 'redo' the file sharing permissions steps if you originally followed them: https://support.bluos.net/hc/en-us/articles/360000197008. 

    (And test with a small folder/subfolder starting off to save time) 

    Regards,
    Sam R.

    0
    Comment actions Permalink
  • Avatar
    Eric

    Log file sent. Thx

    0
    Comment actions Permalink
  • Avatar
    Peter Swanson

    I am facing similar issues after updating to Big Sur. I can access my Bluesound Vault 2 using MacOS Finder, but it all goes wrong if I try and make any alterations. Examples: copying a cover art jpg into a folder, or re-tagging some songs (I use "Tag"). The system locks up, then boots me off the network connection to the Vault (hardwired to the Mac). Interestingly, this seems to throw the Mac's networking capability completely off, since the web browser is also compromised. Rebooting the Mac brings all connectivity back. 

    I have redone the file sharing permissions steps, as advised. 

    macOS App: 3.12.1  BluOS: 3.12.13  macOS: 11.0.1

     

    0
    Comment actions Permalink
  • Avatar
    Gglendon

    I am also unable to mount a library under Big Sur.

    0
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    Hi All

    We have replicated the issue here in our offices. The issue appears to be an Apple issue and not related directly to Bluesound. Apple has made changes to the SMB protocol or what is often commonly known as Windows File Sharing or SAMBA. There are messages about this in a number of macOS sources.

    Please contact Apple for an update or possible fix for this. 

    Thanks for your patience and understanding.

    -1
    Comment actions Permalink
  • Avatar
    Peter Swanson

    Singularly unhelpful! Could you at least provide some more specific references? 

    -1
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    I wish I could but the change was made by Apple when you upgraded to Big Sur. Please contact Apple Support...

    0
    Comment actions Permalink
  • Avatar
    BeansMalloy

    Hi everyone, I managed to find a fix (only took me 21 days since I last wrote on here) and as of writing this, my local share has been going strong for the past 4-5hrs. I know we are all dying to listen to our own music so I'm glad it's an easy fix:

    Head over to System Preferences > User & Groups > Guest User (unlock to make changes)

    I disabled all three check boxes and restarted the computer. Once I was back on, I enabled everything and locked it. Reindex from BluOS if you need but it should start working right away.

    On the BluOS site here: https://support.bluos.net/hc/en-us/articles/360000197008 the instructions I'm speaking about can be found on the PDF from pages 1 through 6. If you've had your system as long as I have, you might have had to do this manually in the past or BluOS applied these changes automatically for us now.

    Hope this helps!

    0
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    Thanks for the tip Beans... glad to hear it worked for you.

    It did not work in our lab. We have also tried removing all permissions and using the Wizard, manually creating the shares, and using a specific ID rather than the Guest ID by manually connecting the shares using the screenshot method you suggested. Though some had margins of success, none of these methods was 100% successful every time,

    We have notified Apple of the issue but encourage you to do the same as well...

    0
    Comment actions Permalink
  • Avatar
    Eric

    Same here. The Guest ID change didn't work for long in my case. Another way to avoid rebooting is to remove the share permission (system preferences/sharing) to your folder (e.g. Music/) and re-grant permission. Then, it may work immediately or 5-10 minutes later if the computer is on. I still don't get how the elapsed time interferes with all of this.

    Another observation: If I keep my power cord connected to my Mac, my hard drive never goes into sleep mode and I have been able to use BlueOS for 3+ days without issue. But as soon as I disconnect the power, even if I'm using my Mac, the problem re-appears. I'm now enabling Power Nap when I'm on battery and report back in a couple of days.

    0
    Comment actions Permalink
  • Avatar
    BeansMalloy

    Sorry to hear it didn't work for you Eric and thanks for following up Tony. Reason I came across this was because when I tried logged in with a guest account, I was asked to put in a password (even though Apple states guest accounts don't have passwords assigned to them). For me, this was the issue — local share hasn't booted me out since this fix.

    Eric, yes I use to have this issue in the past and fix it by keeping Power Nap on my iMac at all times.

    0
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    In continuing to find answers for our consumers, we are seeing more success than failure by Manually creating the network Share under Settings, Music Library, Network Share (rather than The Local Share Wizard), manually enter the path and rather than leaving the username and password blank (assuming Guest) to use the Name and Password you sign in to your Mac with.

    This is not working for everyone but is working for more consumers than not.

    Again we really encourage you to contact Apple about the problems or changes with Guest access since the upgrade to Big Sur

    0
    Comment actions Permalink
  • Avatar
    Eric

    Interestingly, I am no longer able to use the manual method for the network share. The mount keeps failing (sigh). The local share wizard seems to be the only way for me now.

    Tony, you mentioned contacting Apple a number of times. What's the best way to do it...discussions.apple.com?

    1
    Comment actions Permalink
  • Avatar
    Daniel Wharton

    There seem to be several issues with Big Sur remote logins.  I have a persistent problem of not being able to screen share after reboot until I physically log in to the machine, which will become a big problem the first time I'm out of the house and there is something wrong with the machine or power goes out.

    One interesting thing I noticed related to this is that I use a second ethernet port for the smb share when connecting via bluesound.  While I'm having the problem with my library, I cannot authenticate via screen sharing on that IP address.  However, if I screen share to the primary network interface it fixes everything for a time.  So screen sharing gets things working again without a restart or remount of anything.

    This is probably going to be enough to put me over the edge on going back to OS10.  This is just an old trashcan Mac Pro in my closet specifically for server purposes.  I should have known better than to upgrade it.  I thought we were out of the woods on major Big Sur issues  #facepalm

    0
    Comment actions Permalink
  • Avatar
    Daniel Wharton

    My screen sharing trick does not work consistently.  However, I was able to get a slightly suboptimal configuration to work for around 48 hours of continuous play (even over night).  That was not possible prior as I'd always get errors and return to stopped playback within a few hours.

    • I created a 'standard' system user (not admin) for use with bluesound.  I gave it a strong password.
    • Goto Prefereces > Sharing > Options
    • Make sure "Share files and folders using SMB" is checked
    • Under "Windows File Sharing" check the box next to your new bluesound user
    • Click "Done"
    • Select your share from "Shared Folders" and give your new bluesound user read only access to your music share(s)
    • Optional: remove your bluesound user's Public share folder from shared folders as it can only reduce security and is unneeded
    • In BluOS controller add your share using the username and password you set for this new account.

    This will have some security implications as I assume the username and password for this account will be stored unencrypted on your hard drive somewhere.  I also suspect your password may be transferrable in plain text over the network (not certain if bluesound devices will do this).  The risk is pretty low on private networks and computers that stay put at home.  I don't recommend leaving this on for laptops that regularly leave the house (overabundance of caution).  Disable the account or turn on your firewall when you leave the house with the laptop.  Do not use your primary/admin account for this purpose--make a standard user.  You've been warned!

    0
    Comment actions Permalink
  • Avatar
    Daniel Wharton

    I just tried disabling "Windows File Sharing" check on the bluesound user, rebooted my node and was getting errors again within minutes.

    0
    Comment actions Permalink

Please sign in to leave a comment.