NODE 2i optical input disapeared after update to 3.10.0

Answered

Comments

15 comments

  • Avatar
    Bjørn Ulvik

    Happened to me "sometimes" during update. TV was (or not) "smart" and changed from PCM to built in speakers when it lost "connection". I had to manually turn it on in the TV settings.

    0
    Comment actions Permalink
  • Avatar
    Rogier Halkes

    Yes, but my TV is set to optical, and I can see light in the input cable. The strange thing is that the Optical input doesn't show up in the app as it should.  Even with nothing connected to it.  It should be there.

    I suspect this is a bug in the 3.10.0 update, but would hope that support would respond though.

    0
    Comment actions Permalink
  • Avatar
    Mark Everett

    Both Optical and Analogue inputs have disappeared from my top level Android controller screen which appears to be a function of version 3.10.0 of BluOS rather than the updated controller app. Admittedly I don't have any physical connections to these inputs but the selections used to be configurable through 'Customise Sources'. A knock-on effect is that Analogue/Optical inputs cannot be set up in a Preset.

    0
    Comment actions Permalink
  • Avatar
    Sam R.

    Hello all,

    Please ensure you have updated your app to the latest 3.10.1 version. 

    Following that, Rogier, please disconnect the optical cable from both your TV and your Node -- or even swapping the cable out as a test -- reboot the Node, and then reconnecting the cable. It may also help to remove the TOSlink adapter and reseating it in case it's come loose.  

    Mark, the Optical and Analog inputs can be set as a Preset, under the Inputs selection when selecting a Preset source (you will need to have the Analog/Optical input connect when setting the Preset).

    Regards,
    Sam R.

    0
    Comment actions Permalink
  • Avatar
    Rogier Halkes

    Hi Sam

    Thanks for replying!

    I can confirm the right app version, disconnecting/reconnecting, rebooting, swaping cables etc. but with no effect.

    The thing I find strange is that no matter what I can not get the optical source to show up in the app drawer.  No problem with Bluetooth and Analog though.  I have the same problem on both my Ipad and my Android phone.

    The way I think it worked before Bluos 3.10.0 the optical source would show up even if nothing was connected to it.  Am I right?

    /Rogier

    0
    Comment actions Permalink
  • Avatar
    Sam R.

    Hello Rogier, 

    Mostly correct -- if the Node senses hardware connected to the Optical/Analog port, it will determine which and then show up in the app. 

    As a test I just plugged a TOSlink adapter to the back of my Node (2i, 3.10) and the Optical popped right up. Based on your other details I believe a more in-depth look should be taken and so I have escalated your case to our support crew. 

    Regards,
    Sam R.

    0
    Comment actions Permalink
  • Avatar
    Rogier Halkes

    Ok, thank you.

    Would a firmware rollback be a possibility?  If the optical source shows up with a previous a firmware it will tell you something about where the problem may be?

    /Rogier halkes

    0
    Comment actions Permalink
  • Avatar
    Mark Everett

    Hi Sam,

    Thanks for the explaining that the optical/analogue port now detects the presence of connections and reflects this status in the controller app. Does this mean that the 'Hide source' toggle in Settings > Player > Customise Sources is now effectively redundant?

    regards,
    Mark

    0
    Comment actions Permalink
  • Avatar
    Sam R.

    Hello Mark, 

    The port detection has always been this way. Using Hide Source under Settings > Player > Customise Sources still does what it has always done: hide the source so that it does not appear in the BluOS app. 

    I recommend you test this by plugging an optical connection to your Node, and then toggling the Hide Source.

    As a further use case, you can create a Preset for your Analog/Optical inputs and then hide the source if you want less list items in the Navigation Drawer of your BluOS app. 

    Regards,
    Sam R.

    0
    Comment actions Permalink
  • Avatar
    Mark Everett

    That's very interesting Sam. When I first configured my Node 2 (with nothing connected to the input port) I felt sure I had to 'hide' both the analogue and digital inputs from the navigation drawer. Still, this was a couple of years ago now and my memory may be failing me!
    Back to the present and all is now working as per your explanation thanks.

    0
    Comment actions Permalink
  • Avatar
    Rogier Halkes

    Something really weird is going on with my Node2i.  I took it back to the store as requested by support.  Upon arrival the guy in the store hooked it up and there was the Optical source showing up as it should.  Took it home again an everything was ok for some days.  I guess the reason it worked in the store was that the unit was without power for an hour on my way to the store.

    Until yeasterday...  I had to disconnect it from power a few minutes, and after reconnecting, the Optical source was again gone.  Nothing I could do to fix it like last time.  So I figured leaving the unit without power overnight.

    This morning I reconnected power and now when I connect a optical source(with the Toslink adapter) the Analog source pops up in the app drawer, but not the Optical source.  There is no sound either.

    Any suggestions would be really appreciated !

     

    0
    Comment actions Permalink
  • Avatar
    Sam R.

    Rogier, 

    Let us know if the update fixes this -- to note, there is nothing in the update targeting Optical Input on the drawer, but perhaps the action of updating itself will trigger the Optical to come back on the Node. 

    If your Optical does come back, I would recommend creating a Preset for it so that in case it goes away, we can use the Preset to test if only the menu option has disappeared, or if the Node no longer senses Optical for some reason.

    Regards,
    Sam R.

    0
    Comment actions Permalink
  • Avatar
    Rogier Halkes

    Hi Sam!

    So I updatet BluOS to 3.10.3 but the problem persist.

    I have "Hide source" set to off on both analog and optical sources.  With nothing attached to any of them, none of them shows up in the appdrawer.  As soon as I connect the Toslink-adapter to the Node, analog source pops up in the app, but switching to it does not play the sound from the optical source; obviously!
    But why is analog triggered and not optical?  I do not understand this...  But I guess it tells us that connecting the optical adapter does trigger something in the Node.

    Again tried to leave it without power for a few hours, but that didn't help.

     

    /Rogier H

     

    0
    Comment actions Permalink
  • Avatar
    Sam R.

    Rogier -- " As soon as I connect the Toslink-adapter to the Node, analog source pops up in the app, but switching to it does not play the sound from the optical source; obviously!"

    Do you mean that connecting the Optical/TOSLink cable then triggers Analog Input to show up in the app? If so, that makes this even more peculiar. 

    If you haven't tried already, would you be able to install the BluOS app on your PC (Win or Mac) and see if Optical shows up there? Or if Analog, or nothing at all shows up.

    Also, use the flashlight on your phone and shine it into the Analog/Optical Input port on your Node, make sure there isn't any small debree in there that might be interfering with the detection mechanism. 

    Regards,
    Sam R.

    0
    Comment actions Permalink
  • Avatar
    Rogier Halkes

    Hi Sam

    Yes that is correct.  I connect the Optical/TOSLink cable and it then triggers Analog Input to show up in the app, not Optical.
    I understand that this might sound weird so I could take some pictures showing this if that helps? 

    I have BluOS installed on a PC, with the same results as on my IOS and Android devices. 
    Also checked the input for debree, but could not see anything.

    Just to eliminate other possible factors I also tried both Wifi and Ethernet connections, but that didn't solve anything either.

    /Rogier H

    0
    Comment actions Permalink

Please sign in to leave a comment.