Lip Sync - Node 2i (digital out)

Answered

Comments

26 comments

  • Official comment

    What happens if you use analogue out? We often see external DACs adding their own delay.

    We cannot lower the delay lower than 50ms for multiplayer grouping reasons.

    Comment actions Permalink
  • Avatar
    Juha

    Do not have analog cables to test.

    Understand 50ms requirement for groupping. But it would be great if lower delays would be available when groups are not in use.

    0
    Comment actions Permalink
  • Avatar
    Juha

    What is the delay when AV sync is off? Feels that it much more than 50ms. If thay would be close to 0ms, I could adjust rest from speaker end.

    0
    Comment actions Permalink
  • Avatar
    Sam R.

    Hello Juha, 

    I have escalated your case to our support crew -- it may be best to work with them to troubleshoot this further. 

    Regards,
    Sam R.

    0
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Hello!

    I just bought a brand new Powernode 2i and having annoying lip-sync issue as well while using it with my LG tv. 

    I've tried analogue / ARC inputs, the issue exist on both.

     

    Can you reveal Bluesound's plans and timings on this issue please?

    I hope you will update the firmware to allow us to use less than 50 ms lip-sync delay while not using groups.

    0
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    Hi Evgenii

    As mentioned, for grouping reasons we cannot lower the timing to less than 50ms. This level is in fact lower than the industry standard for multipurpose streamers.

    If you have no intention of grouping your players, you can try disabling A/V Mode all together, but that may worsen the issue. It will worsen the issue if you group your POWERNODE to other players.

    Please also consult your TV and other devices in the audio chain to ensure they are not adding delay as well.

    0
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Hi, Tony!

    Only thing changed in my audio chain is Powernode, and I have never seen noticeable delay before.

    >As mentioned, for grouping reasons we cannot lower the timing to less than 50ms. This level is in fact lower than the industry standard for multipurpose streamers.

    But I'm not using groups at all and don't plan to, why can't you just allow me to lower timing while no groups present?

    Logic in this case can be that simple: 

    1. There are any groups? Lock minimum delay to 50 ms.

    2. There are no groups? Unlock minimum delay or lock it to real hardware minimum.

    3. Group added, but selected delay is less than 50 ms? Raise it up to 50 ms and lock minimum delay to 50 ms.

    1
    Comment actions Permalink
  • Thanks for your feedback

    0
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Sure, but what about my request?

    I like your product, it's really nice and convenient, but delay in movies is killing me.

    I don't want to use groups, so 50 ms looks like some artificial restriction for my amplified stereo-only setup.

    Do you plan to do something about it? Is there are any options to get rid of it? Maybe some hidden engineering menu, or something like that?

    1
    Comment actions Permalink
  • Avatar
    Juha

    Evgenii,
    I have exact same issue with Node 2i.
    my support request has been without any action/response for 10days.

    Have a feeling that they don't take this seriously and have no plans to fix it

    0
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Juha,

    I hope that's just a misunderstanding and guys will pay some attention to TV users as long as their products have HDMI onboard and is clearly intended for use with TVs.

    I tested "A/V mode" yesterday, delay became even worse with A/V mode disabled.

    Juha, let's do this in a proper way: follow this link, comment and upvote it, please https://support1.bluesound.com/hc/en-us/community/posts/360047214174-Lip-sync-issue-request-for-low-delay-mode-to-watch-videos-

    0
    Comment actions Permalink
  • Avatar
    Juha

    Evgenii, found following from logfile

    When Disabling AV Mode
    Jun 18 17:35:41 (none) user.info ./ms.pl: CaptureCodec::setLatencyLimits CaptureCodec.pm (265) lowLatency=0 latencyLimits=250,1000

    Jun 18 17:35:41 (none) user.info dspout: Command(l=10): L250

    Jun 18 17:35:41 (none) user.info dspout: capture_latency: 50000µs -> 250000µs

    When Enabling AV Mode (50ms)

    Jun 18 17:35:47 (none) user.info ./ms.pl: CaptureCodec::setLatencyLimits CaptureCodec.pm (265) lowLatency=1 latencyLimits=50,150

    Jun 18 17:35:47 (none) user.info dspout: Command(l=8): L50

    Jun 18 17:35:47 (none) user.info dspout: capture_latency: 250000µs -> 50000µs

    So looks like Disabling AV Mode sets Delay to 250ms??? Should go to other direction (close to 0ms)

    1
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Juha, wow!

    That's really impressive, thanks for exact numbers.

    Yeah, that is really looks like disabling A/V mode sets delay to 250ms – 250 000 microseconds.

     

    I will take a look at the logs as well, looks like we can get some more interesting info out of it.

    0
    Comment actions Permalink
  • Avatar
    Ioan Cristian

    have same issue with Bluetooth. Very annoying while watching videos.

    0
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Hello, Tony!

    A lot of time have passed and I’m coming back with exact same questions.

    Do you plan to do something about it? Is there are any options to get rid of delay? Maybe some hidden engineering menu, or something like that?

    0
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Issue is still here with us, it will not disappear magically

    0
    Comment actions Permalink
  • As mentioned, thanks for the feedback but BLUESOUND Players do not include analogue or home theatre bypass as their primary purpose is a multiroom playback system.

    Your feedback has been passed along for future consideration.

    0
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Tony, the thing is:

    1. Bluesound Powernode 2i owners manual located on your website at https://www.bluesound.com/wp-content/uploads/2019/08/POWERNODE_2i_Owners_Manual_July2019.pdf states the following:
    "HDMI ARC: Using an HDMI cable, connect one end to the HDMI ARC input of the POWERNODE 2i and the other end to an ARC-enabled HDMI output on your television. You may be required to enable ARC in your TV settings. Consult your user manual for more information. The HDMI source will appear as HDMI in the Navigation Drawer of the BluOS App."

    2. Powernode page on your website is featured with pictures of a Powernode 2i as a center of home theatre system:
    2.1. https://www.bluesound.com/wp-content/uploads/2018/08/POWERNODE-2i-Feature-x-On-credenza-with-TV.jpg - even the name of picture here
    2.2. https://www.bluesound.com/wp-content/uploads/2018/08/WHT-POWERNODE-2i-amp-large-speakers.jpg

    3. Video introducing Powernode on a Powernode page depicts Powernode 2i as a center of home theatre system https://youtu.be/VSBPYW87szM

    So Bluesound Powernode 2i is clearly designed and intended for use with TV as a center of home theatre system.

    We, your users, have a problem which is spoiling our experience with your great product.

    First problem was reported 4 years ago, it's already enough time passed for you to consider it.

    But all we're getting is "thanks for feedback" and attempts to assure us that this should be this way.

    Instead of something substantial like promise to fix it in some adequate time.

    So please contact the developers and return with something real.

    2
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Hi, Tony!

    Can you explain why don't you want to help us with this issue please?

    It is definitely a minor issue and it can be fixed by almost any developer in minutes. Maybe little more if you will choose to implement some logic or extra UI around the solution.

    We have found the exact problem – it's the artificial delay added with some Perl-script command:

    Jun 18 17:35:47 (none) user.info ./ms.pl: CaptureCodec::setLatencyLimits CaptureCodec.pm (265) lowLatency=1 latencyLimits=50,150

    Jun 18 17:35:47 (none) user.info dspout: Command(l=8): L50

    Jun 18 17:35:47 (none) user.info dspout: capture_latency: 250000µs -> 50000µs

    You can just allow us to use values down to 0 here and that's all, problem fixed.

    And you will have one more qualified answer in your personal Bluesound knowledge base ;-)

     

    PS: I've managed to measure audio lag and found it's around 90-92 ms. Looks like ~40 ms is the sound processing delay and 50 ms is the controllable one.

    2
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Juha, I have contacted Bluesound via Facebook as long as support is ignoring us on forum and got answer from their PR (I think so) team.

     

    >Hello Eugene,
    >Our BluOS Support Crew has informed us that the issue you are experiencing has been reported to our QA Lab for further investigation. Although it may seem like a simple fix, our support team has assured us that it does require further testing.
    >We appreciate your patience and encourage you to contact them if you have any further questions.
     
    I hope that support team will answer us here from now on.
    If not, we can always contact Bluesound management on Linkedin or Facebook to ask if there is some progress on the issue.
    0
    Comment actions Permalink
  • Hi Evgenii

    We are not ignoring you. As mentioned, it is a current limitation of 50ms. The reason why are discussed above. Also as mentioned, it has been passed along to our Quality Assurance Team for review. Based on the response from our Social Media team, you see they are in fact reviewing it. Unfortunately, these are not quick fixes and do take time. This is also exasperated as our QA Team is no longer physically located in the lab but working out of their homes due to our organisations commitment to slow or halt the spread of COVID-19. 

    The lag you are seeing of 90ms indicates other factors are contributing to the problem such as perhaps, your other equipment such as the TV and/or poor network signal to the rear players which can be looked at here; www.bluesound.com/network101. 

    Thanks for your continued enthusiasm and feedback, and for #LivingHiFi.

    0
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Hello, guys!

     

    Any news on the issue?

    1
    Comment actions Permalink
  • Avatar
    James Jordan

    I'd like to add my voice of support to this issue. We're experiencing lag that actually feels more prevalent than when I first set up my PowerNode 2i. This is the centerpiece of my living room sound system for both music and tv/movies, and I have no plans to add any groups. I would greatly appreciate a low latency mode.

    1
    Comment actions Permalink
  • Hi James - please select Help, Send Support Request so we can help diagnose the apparently added lag...

    0
    Comment actions Permalink
  • Avatar
    Evgenii B.

    Tony, that's what people call "ignoring" – I've asked a question more than a week ago and you ignored me.

     

    You are clearly unwilling to communicate, this is unacceptable.

    0
    Comment actions Permalink
  • Avatar
    Joseppe

    Just bought the node 2i and indeed an unexpected audio delay. So now I need to directly feed my active speakers and switch with a remote (which I thought I wouldn't need anymore after buying Bluesound) to switch to TV sound (and back!) which would otherwise be automatic. Would be a great fix....!

    0
    Comment actions Permalink

Please sign in to leave a comment.