Artwork and cache Android App

Answered

Comments

8 comments

  • Official comment

    Hi Christian

    Please keep working with Jon on our level 2 team.

    RX Packet errors suggest that there is in fact an issue receiving the updated information from the players if the cache is in fact corrupted. The two are most likely related...

    Comment actions Permalink
  • Avatar
    Christian

    Understood, but if that is the case, the question is why the cache is corrupted on all 3 devices running android and what is the solution.

    I have sent another log, hope to get a fix of this issue soon.

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Blackbird

    Has this bug been fixed already? As I know, Android has different methods for caching list views. However the BluOS app isn't doing that very well...

    0
    Comment actions Permalink
  • Hi Blackbird - this isn't a bug - this is a problem with your network. We will be happy to help troubleshoot by selecting Help, Send Support Request in the App.

    0
    Comment actions Permalink
  • Avatar
    Blackbird

    Not sure, why my network is the problem - just three devices (tablet, powernode, pulse mini) and an access point are active within a small room. When using the network for other things, I'd never had any problems (high latency, packet loss, CRC errors, etc.)

    But maybe I'm wrong, so please give me a hint what I can do to solve the problem.

    Before that, I would like to know if the artwork will be cached on the android device or not. If this would be done, scrolling up and down should show the covers instantly (at least as soon the cache has been built), but this doesn't happen. So I see only two explanations (beside a network problem):

    - the app has'nt been optimized for speed (tuning an image list can be tricky within android)

    - the app is fetching the covers each time again and again. If so, the delay would be clear (transferring just 10 covers with 50KB each over a 50Mb-WLAN needs 100ms at least).

     

    0
    Comment actions Permalink
  • But maybe I'm wrong, so please give me a hint what I can do to solve the problem.

    We will be happy to help troubleshoot by selecting Help, Send Support Request in the App.

    0
    Comment actions Permalink
  • Avatar
    Christian

    Interesting you have the same problem. My problem was never solved and is still existing. Even a remote session was no success. I switched cables, switch etc. - nothing helped.

    I told this before: No problem with ios and windows devices.

    As far as i remember (it's a long time ago) i was told that the problem will be forwarded to the development team. It would be interesting what happens in the meantime.

    0
    Comment actions Permalink
  • Avatar
    Blackbird

    Maybe it has to do with the network but I don't have any explanation how this could influence an already cached list.

    I would guess that the reason for this behaviour is unefficient program code in the android app. It is not that easy to do image lists ("views") perfect in android.

    0
    Comment actions Permalink

Please sign in to leave a comment.