Comments

11 comments

  • Official comment
    Avatar
    Wesley P.

    Hello Alf,

    I'm sorry to hear you are experiencing issues with your C368. I will escalate this as a request to our support crew to investigate this further and provide you with a solution as soon as possible.

    Regards,
    Wesley P.

    Comment actions Permalink
  • Avatar
    Reagan Chandramohan

    Upon choosing to upgrade BluOS on my NAD C388 amplifier via my Android phone BluOS app, I'm now also experiencing the same behaviour as described here. The amplifier displays the message "Executing BluOS Upgrade" for about a minute and then shuts down. I'm not able to select the BluOS Reboot or BluOS Reset options in the amplifier BluOS Setup menu. Any suggestions on how I may be able to resolve this issue? Would appreciate your prompt response to this since being unable to use our amplifier is significantly impacting us.

    1
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    Hi Hidde - your issue has also been escalated

    1
    Comment actions Permalink
  • Avatar
    Matthew M

    I was able to resolve my issue by reinstalling firmware from USB

    1
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    Hi Reagan

    We will be in touch

    0
    Comment actions Permalink
  • Avatar
    Hidde

    I'm experiencing the same issue on my C368. Can't use the control menu as it is stuck in 'executing the BluOS upgrade'. 

    Music drops out every couple of minutes when streaming.

    0
    Comment actions Permalink
  • Avatar
    HJK

    Hi,

    same to me ;-(

    Nevertheless, streaming via BluOS MDC module seems to work for for tune.FM station stored as preset?! 

    0
    Comment actions Permalink
  • Avatar
    Matthew M

    I have the same issue. My NAD 368 is stuck on the following screen. Should I create a support ticket, or are there steps online to resolve?

    0
    Comment actions Permalink
  • Matthew - consider a DHCP reservation in your router for future-proofing as BluOS Players technically reboot twice during an upgrade so could be your router is mismatching the MAC Address of the Network Card on the Player.

    0
    Comment actions Permalink
  • Avatar
    Paul

    New C388, I was prompted to upgrade the Bluos firmware a few days ago and every time I turn the unit back on it goes to "executing Bluos upgrade" and never completes.  The BT streaming still works but I am not able to get this to complete the upgrade.  Any ideas on how to get this to complete the upgrade?  I did download the Bluos firmware below but not sure if this is the latest and the manual is not clear on how to do an upgrade via USB.  So I am concerned this will create a bigger issue then just having that message.  THoughts ??

     

    https://nadelectronics.com/product/c-388-hybrid-digital-dac-amplifier/

     

    0
    Comment actions Permalink
  • Avatar
    Wesley P.

    Hello Paul,

    The steps on performing a manual BluOS updates can be found in the C 388 Software Upgrade Procedure document found on the C388's download page.

    Please follow the steps provided on page 7 and if the issue persists, contact support@nadelectronics.com directly for further assistance.

    Regards,
    Wesley P.

    0
    Comment actions Permalink

Please sign in to leave a comment.