Gapless playback for MP3 using LAME header information?

Answered

Comments

5 comments

  • Official comment

    Hi Franz

    I would check your tags or your encoding process as we in fact have have not had issues (I'm a bit of a live music snob myself). If problems persists, please select Help, Send Support Request and we can arrange for a sample of 1 or 2 tracks to dig deeper and find out why you are seeing this...

     

    Comment actions Permalink
  • Avatar
    Franz Nieroster

    Hi Tony,

    I did what you suggested. But the result was rather disappointing. First the Support team claimed that gapless playback is working perfectly with the samples I've sent them until I sent a screen shot of a waveform (attached) recorded from the headphone jack of the Pulse Flex 2i. Since then I got no answer at all.

    So for all, who want to inform themselves before buying a Bluesound product I will post the results of the support ticket here:

    Uploaded sample files: http://www.share-online.biz/dl/RHIK6HVPSS

    "Further testing here has been performed and results below.
    The first track has 3 seconds of no audio according to foobar.
    Otherwise all the tracks played fine both from a USB OR a library created through a network share - with gapless being clearly shown after the first track.
    You should attempt playing a track that's greater than 1 minute mixed with others and verify if this works for you.
    We start processing the next song around the last 15 seconds of a currently playing song, which allows gapless playback to commence.
    If your files all match the example you've provided us - that's likely the problem."

    Of course this analysis is pure non-sense. Fact is that the LAME header information is not used at all for gapless playback. So the statement: Bluesound Players offer gapless playback by default for all supported file types (BLS-KB13-X01) simply isn't true. Also the fact that the ticket (142797)  was closed without further notice does not look very customer oriented to me.

    I have the impression that nobody at Bluesound understands that gapless playback of mp3 files is not just concatenation. The decoder has to actively remove samples to compensate for encoder delay and padding. Here is some general information about gapless playback of mp3 files: https://wiki.hydrogenaud.io/index.php?title=Gapless_playback, here is another page: https://www.wikiwand.com/en/Gapless_playback. My audio files that are supposed to play gapless are all encoded with LAME. Using the additional header information Winamp, foobar2000 and many more play these tracks gapless on a Windows PC. The same is true for PowerAmp and BubbleUPnP on Android. These are all software solutions. The only hardware solution I found so far is an iRiver H40 player using the Rockbox firmware. So I’m pretty sure this should be possible for the Pulse Flex 2i too. It just needs to be implemented properly. To me it seems that nobody at Bluesound is interested.

    Franz

    0
    Comment actions Permalink
  • Hi Franz

    Thank you for your detailed feedback. We have in fact looked at your case and have concluded the problem you are seeing was generated during your encoding process and the settings used when created. The issue you are seeing is caused by gaps generated during that process. We recommended you try re-ripping Chris Rea's Espresso Logic with another encoding tool and compare those results. 

    Thanks for #LivingHiFi

     

    0
    Comment actions Permalink
  • Avatar
    Franz Nieroster

    Hi Tony,

    how can your conclusion explain that the files play perfectly gapless on the mentioned players? Try Foobar2000 and you'll see/hear.

    Franz

    0
    Comment actions Permalink
  • Avatar
    Franz Nieroster

    Hi Tony,

    Just to let you know that we are going to return our Pulse Flex 2i. Ignoring a problem, reported in detail by a customer and reproducible by anyone, does not solve it. Furthermore it does not seem to me to be the right approach for a support team.

    May others get happy with your products. We have given up.

    Franz

    0
    Comment actions Permalink

Please sign in to leave a comment.