Tunein Favourites missing via Most Used menu from Home Screen




  • Official comment
    Morten N.
    Brand Manager

    Hi Phil.

    That sounds strange. Can you try deleting your app and reinstalling it from Google Play.

    If this does not help, please feel free to use 'Send Support Request' from the app and our Support Crew will look into it.

  • Phil 3100

    Just tried the Windows app 4.2.0. I can see Tunein Favourites by clicking the favourites button within the Tunein box in Most Used on the Home screen, but if I try to open the Favourites screen from the main menu, I just get a blue spinning circle with the message "Just a moment..." which never completes.

    Also, clicking the Learn More button for the Tidal connect Max notification on the Home screen in the Windows app takes me to a screen which says "Oops The page you were looking for doesn't exist". It links to the correct page in the Android app.

    I have rebooted my Node, with no difference. It is on an ethernet connection with a fixed IP on the LAN.

  • Rolf Stäger

    If I deactivate the new user interface in BLUOS 4.2 then I have the Tuneln favorites back..

  • Phil 3100

    Thanks Rolf. Just checked and the same happens here, so it appears to be the same issue.

  • Rolf Stäger

    Now it works just fine for after the last update thanks

  • Phil 3100

    Which update is that Rolf? I am on BluOS 4.2.6 and Android 4.2.2 build 2852. No updates available here and for me the issue remains. I've held off on reinstalling the app for now in view of your post though, as I'm convinced that it's a software issue, particulalry as it work on reverting to the old interface.

  • Tony W.
    Product Support Manager

    Hi Phil

    Fixed in Android 4.2.3 available now in Google Play

  • Phil 3100

    Thanks for letting me know Tony. I'm not being offered it here yet, but as soon as I get it I'll let you know the result.

  • Phil 3100

    OK, I'm getting somewhere, but it seems a bit strange. Android 4.2.3 initially made no difference - clicked on Favourites and the list of TuneIn favourites flickers briefly then the screen goes blank apart from the "Favourites" title, just as before. Then I had a thought - I first noticed the issue after deleting a custom URL from my favourites - BBC Radio 2 HLS stream which the BBC killed in October. I'd left it in the list after the official BBC streams reappeared in TuneIn, but decided to delete it after updating to one of the Android 4.x releases, probably two or three updates back.

    Anyway, I decided to try adding another Custom URL in TuneIn. First I tried a stream for NASA Third Rock Radio, which I added successfully to my favourites even though the AAC URL I found online didn't work. BUT after adding that custom station to my favourites, all of the TuneIn favourites appear normally when selected from the Favourites menu and the link within the TuneIn icon within the Most Used section of the Home screen.

    So I then deleted the non-working custom URL. Back to square one - selecting the Favourites screen from both methods as above, a brief flicker and the screen goes blank. I added another (non-working) URL for a BBC radio stream that was supposedly still live post the October BBC chop - favourites accessible and working as expected again. Delete the Custom URL, back to a blank screen.

    If I revert to the old user interface, favourites all work as expected, with or without custom URLs. Back to the BlueOS 4x interface, and the screen is blank unless I add a custom URL.

    So as long as I keep a custom URL defined in TuneIn - even if the URL doesn't actually work - but as long as the custom URL is added to my favourites, the Favourites screen is being populated as expected. 

    Edited to add: Just noticed that I also see an Add Custom URL icon in the URLs section of Favourites after I have added at least one custom URL. If I delete or don't have any custom URLs set up, I don't see the Add Custom URL icon either. I don't know if that is significant?

  • Phil 3100

    OK, I created a new post on this issue  simply because:

    1. This thread had been marked as answered as soon as Tony stated the issue was fixed in Android 4.2.3, despite my reply that I would try it and report back.

    2. Another thread from a different user apparently referencing the same issue had also been marked as answered, when he also reported it wasn't fixed after the update:


    3. As both threads had been marked as answered and no official comment had since been made to either of them following posts stating the problem persisted, I wasn't sure whether threads marked as answered would be reviewed further.

    I have now had my knuckles rapped for starting another thread. I only know this because of the email I received notifying me that a reply had been made to the new thread by @Tony W. He informed me that the new thread would be closed. However it instead appears to have been completely deleted because the link in the email notification tells me that the thread I'm trying to view doesn't exist.

    Anyway, Tony W's reply was quoted in the notification email, so luckily I was able to read it. After the telling off, it continues:

    ... the issue is being caused by information sent to your Bluesound Player to update the app is not being updated timely. Reboot your router, wait 5 minutes (the waiting 5 minutes is important). Reboot your Player, wait 5 more minutes, then relaunch the App. These timings will allow systems to fully boot and establish network gateways.

    @Tony W - I apologise for starting a new thread unnecessarily, but as a relatively new user of the forum I wasn't sure whether the two threads marked as answered were being read for further replies. I now know that they are, so I won't do it again!

    In answer to your comment above though, I have already tried rebooting both router and player, and flushing my network to no avail. The player is on a wired LAN with a fixed IP address.

    If the problem with Favourites not populating is a network timing issue as you say, can you explain why it is instantly fixed by either reverting to the old v3 interface in the app, or creating a TuneIn custom URL within the v4 interface as I described above, and can be instantly reintroduced by changing back to the new v4 interface or deleting the custom URL if already present within the v4 interface?

    Surely if there was a network timing issue these changes would either take some time to take effect or would constantly require the player and router to be rebooted as you suggest? Wouldn't the timing issue exist across both the v3 and v4 interfaces also, creating the same issue in both? That's not what either I or the other poster were seeing.

    Anyway, I've lost the will to keep fiddling with this. Having added a custom URL in TuneIn (albeit one that doesn't actually work because the stream is no longer available) the Favourites screen and access to TuneIn favourites through the TuneIn icon in the Most Used section of the Home screen both work as expected for me in v4.2.3, so I'll leave it at that.


Please sign in to leave a comment.