Roon Groups Still Out-of-Sync



  • Official comment
    Tony W.
    Product Support Manager

    Before using ROON, please open the BluOS App and break all groups you may have. This includes any fixed groups such as Stereo Pairs. 

    Group only using ROON. If you have Sync problems, please contact ROON.

  • Brian

    Thank you for the reply Tony.

    Over the past few months I have done all you've suggested, broken the groups in BluOS and contacted Roon with no success. I will try yet again.

    Both parties seem to think the other may be at fault.

  • Anton Westbergh

    I can just pitch in here as this is exactly the same issue I have (that I have been talking with you Tony about.) Can confirm that "only grouping using Roon" does not help. Issues occur for me both on NAD CI580v2 and Bluesound Node 2i. (all hardwired on ethernet.)

    For me Roon only works with Bluesound playing to a single "bluesound zone". As soon as I group up two or more devices that include a Bluesound-device, various grades of instability occurs. I had a long thread on the mail with Bluesound support and was confirmed that the report would go to tech but I haven't heard back since.. (At the same time Roon works great for me with any other devices I use, such as Devialet Phantoms, or even Raspberry Pi's running Roon endpoint software such as Ropieee or Hifiberry OS). 

    It is frustrating to see responses like this telling users to talk with Roon.. it's like.. if Roon works great with other branded devices, so how about Bluesound actually pick this up seriously and give us some real transparent response? I am 100% certain you will be able to reproduce these issues if you hook up some devices and try out Roon.

    Isn't this the support forum for Bluesound devices?..

    Perhaps there has to be work between Bluesound and Roon, but at least confirm the issue. These devices are sold as "Roon Ready" so at this time this is actual marketing fraud. I am sure plenty of people buy these devices just on this premise.. and as me, you end up in this nightmare trying to figure out what is wrong. 

    I had a similar journey back in 2019 when I had some older Bluesound devices (PowerNode, Flex, etc).. I ended up switching my entire network setup two times as Bluesound just blamed my networking, ending up costing lots of money.. In the end I sold all Bluesound devices and moved on to other brands which worked great..

    In 2022 in relation with setting up a multi-room system, I (stupidly) decided to give Bluesound another try with NAD CI580v2, and I wish I went with another solution because these types of issues seems to still persist, and just as in 2019, the support is just reflecting and not helping out.

  • Brian

    @ Anton

    I concur, neither Bluesound not Roon are taking this issue seriously. I have a lot invested in NAD and Bluesound equipment (M33, C658, C368, Pulse's, Flex's). I chose the BluOS ecosystem because I'd been a NAD customer for decades and trusted the brand. At one point Bluesound support suggested the issue was due to older network cables and advised upgrading to Cat6e. I did so as well I upgraded the entire network to 6E mesh. Still no joy. TonyW means well but is not a Roon user and has no direct experience regarding out-of-sync.

    I've ungrouped in BluOS, rebooted every device, added them back to the network, one-at-a-time, made sure to have DHCP reservations for Bluesound, my NAS and Roon Core. Sometimes this resolves the issue temporarily but it returns. I recently tried wiring one of the offending Flex's to a mesh router which worked until one of the grouped pair (both wired) dropped out completely. Clearing the Play Queue and restarting play resolves it temporarily. 

    It's clear to me the issue originated with a BlueOS update in Spring 2023 as grouping in Roon worked flawlessly before that.

  • Joel

    Chiming in here as yet another frustrated BluOS / Roon user (using several Node devices, an NAD AVR, Ethernet connections, etc.) with ongoing sync problems that were never present before last year. Roon support is nonexistent (evidently, not responding to forum threads at all is their idea of “support”). BluOS support acknowledges the problem but provides no explanation, plan for resolving this, or timeline. Do the two support teams communicate? Why the secrecy, finger pointing, and lack of follow through? These expensive devices are purportedly “Roon Ready” but they can’t manage multi-device syncing with reasonable reliability. What can we do to get a productive response to this problem?


Please sign in to leave a comment.