Airplay 2 problem Node 2i

Comments

12 comments

  • Official comment
    Avatar
    Tony W. - Product Support Manager

    The Airport Express is an older router/repeater and may have problems with the 5G band... Try disabling it or if you still can, set it to 802.11n only disabling 802.11g and see if that helps. as suggested, Help, Send Support Request will also let us take a closer look.

    Comment actions Permalink
  • Avatar
    Seppi Evans

    If you if you bring your iPhone / iPad close to your router which I am assuming is also a WAP do you still get the issue?

    0
    Comment actions Permalink
  • Avatar
    Richard Gray

    I have sufficient wifi coverage thanks, as said my mobile devices can Airplay to every other device* apart from the Node 2i just fine.

    *For reference: 2 x HomePods, 2 x Yamaha MusicCast devices (a Wifi connected speaker, and an Ethernet connected WXAD-10), and an Airport Express 2 as said on Ethernet only.

    So a mix of Wifi and Ethernet Airplay devices that all work fine from mobile devices, expect the Node 2i.

    0
    Comment actions Permalink
  • Avatar
    Seppi Evans

    Curious…

    Try with the Airport Express unplugged from the mains

    Check you have the latest BluOS firmware

    Personally I would factory rest the Node but you may want to log a support call first with Bluesound.

    0
    Comment actions Permalink
  • Avatar
    Richard Gray

    Seppi, makes no difference with the AE unplugged.

    Yes latest firmware on the 2i.

    Tony, - the Airport is connected via Ethernet only, which I have stated twice. Neither the 2i or the Airport are connected via any Wifi 2.4ghz or 5ghz.

    0
    Comment actions Permalink
  • Avatar
    Seppi Evans

    The Node is on Ethernet but your iPhone / iPad use WiFi.

    Next steps as Tony says… log a call

    0
    Comment actions Permalink
  • Avatar
    Richard Gray

    Yes I know that, that's literally what I've said in my posts. And that also I have 2 other Airplay devices on Ethernet only which work just fine with my mobile devices on Wifi (again as I've said). - And I've also had 3 routers and that the only thing that has never worked in ANY of these combinations is the 2i...........

    I will raise a case.

    0
    Comment actions Permalink
  • Avatar
    Matthew Wai

    Hi Richard,

    Is the problem you had about the airplay connection on node 2i solved?
    I have the same issue that if I play music via airplay, the music keep jerky. I suspect could be my router problem, but when I tried to airplay to apple tv4k, no issue at all. 🤔🤔🤔

    0
    Comment actions Permalink
  • Avatar
    Richard Gray

    No not solved, after some useless email exchanges where support closed the case after every response (despite not resolving it!) - I’ve given up.

    I was getting an issue with mostly using Foobar2000 - and so they concluded it must be the codec it’s using. Which is absolute BS because it’s basic red book material and works fine to my other 6 Airplay devices!

    I’m now getting jerky music on Apple Music’s app too, so again it’s not the sodding codec ffs!

    I’m looking for another streamer now, annoyed beyond belief with such god awful support - and will no longer recommend Bluesound again.
    I should have known better, NAD’s an awful company with buggy unreliable products (never had such a piece of junk as the C368 before) - so I guess it has rubbed off on Bluesound.

    Google is fairly littered with Airplay problems on the Node’s, I wouldn’t blame your router (Ive had 3 and still the problem persists).
    Shame because for natively library playback the Node 2i is excellent. But it’s integration with Amazon Music is beyond dire, so I’ve switched to Apple Music now that’s going lossless - however I can’t get Airplay to work to it. Junk, with junk support.

    0
    Comment actions Permalink
  • Avatar
    Matthew Wai

    Hey Richard,

    It’s awful to hear.
    Yea with Apple going to loseless definitely need airplay a lot. I just tried bluetooth, it’s connected but no sound at all, can’t believe it.
    Bought it several months and all the while was working alright by direct streaming tidal etc via bluos. Until lately I subscribed KKbox and Apple Music found out this airplay & Bluetooth issue.
    I thought the 2i was suppose to do the airplay work from its older generation.

    Restarted my router and reset the node2i numerous time but it seems every song I played via Airplay jerky from the start.

    Shame if they can’t solve this issue.

    Disappointed as I logged in report on their page but not responded.

    0
    Comment actions Permalink
  • Avatar
    Matthew Wai

    Hey Man, I think I figured out the problem.
    There is a setting from BluOS to enable the Audio Clock Trim which I always on.
    For airplay if you on the audio clock trim meanwhile you are using external dac via optical/coaxial out, then the sounds would be jerky.
    I tried either you disable the audio clock trim (using external dac) or you connect rca using internal dac of the node2i in the case you think it is better to keep the setting on.
    Hope it helps, cheers.

    0
    Comment actions Permalink
  • Avatar
    Richard Gray

    My audio clock trim was already disabled (I use an external DAC), my understanding was better to not have BluOS fiddle with the signal? However in either setting it doesn’t work with Foobar trying to Airplay to it :( … but, Apple Music has started streaming again to it just fine - which is all I actually need Airplay for anyway.

    So, fingers crossed it maybe just needed that setting toggling on/off. And hopefully then not a premature thanks very much for the tip!!

    0
    Comment actions Permalink

Please sign in to leave a comment.