gapless playback

Answered

Comments

18 comments

  • Official comment
    Avatar
    Tony W. - Product Support Manager

    Hi Jay

    Gapless playback means the next song is queued and added to the buffer before the current song is completed and seamlessly begins upon completion. In older or systems or computer streamers, the buffering would not start until the current file ended processing causing an audible silence between songs, like a hic-up or gap in sound. There is no way to defeat this, and why would you want to.

    Comment actions Permalink
  • Avatar
    Jay Newman

    Thanks!

    Just trying to understand what it is, and now that you've explained, I agree, I wouldn't want to defeat it. Had been reading a review about something that still didn't have it, and I noted that both you and Roon supported it so I must have it.

    On a separate note, I do have occasional gaps in sound, but not between tracks.  Music will suddenly pause for a second or three. Should I address that here or elsewhere? 

    0
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    Hi Jay

    Send us a support request from the Help menu of the App. Those are most likely network related issues. Our BluOS Support Crew will give you some tips and tricks based on your specific environment.

    0
    Comment actions Permalink
  • Avatar
    Randy Showalter

    I noticed recently that my Bluesound Node 1 is playing some MP3 albums with tiny gaps between tracks. I've had this Node for years, and I've never noticed this issue before a couple of weeks ago. Is this just a limitation of certain MP3 encoders, or has something changed in the Bluesound firmware?

    0
    Comment actions Permalink
  • Avatar
    Randy Showalter

    The MP3 album I'm listening to right now exhibits this problem. According to the tags, it was encoded by ITunes 12.7.3.46. Could ITunes be the cause?

    0
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    Hi Randy

    We have made no changes here...

    Help, Send Support Request will send us a log file to help troubleshoot what is going on here...

    0
    Comment actions Permalink
  • Avatar
    Paolo M.

    Hi Tony, 

    I've recently purchased a new Bluesound Node 2i and I can't seem to have gapless playback which makes listening to records such as The Dark Side of The Moon quite frustrating an experience.

    I've tried both via Spotify Connect and YouTube Music Premium, which are my main streaming platforms, and with both I had no success. However, gapless playback seems to be supported when using Apple Music. 

    I should add that I also have a Marantz NA6006 streamer which works seamlessly with gapless albums playback via Spotify Connect (including Dark Side of the Moon).

    My system is: iPhone XR with iOS 13.2; Bluesound Node 2i; Marantz PM6006 UK edition. 

    Thanks,

    Paolo

    0
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    Hi Paolo

    Thanks for the feedback - we have heard a lot of complaints about how Spotify implements Gapless playback. We have checked our implementation and it is according to their specs. That being said, Spotify's gapless playback doesn't work in my experience with my car's audio Bluetooth either. Not an excuse, an observation.

    The fact it works with Apple Music but not YouTube indicates the problem is not AirPlay but the service itself.

    Maybe this is an indication for you as to which service works best for you... ...or where the problem lies between Us And Them

    ...sorry, couldn't resist...

    0
    Comment actions Permalink
  • Avatar
    Paolo M.

    Hi Tony,

    Thanks for getting back to me. Fair enough... :D 

    I agree, after some further testing it's now clear that the issue doesn't lie on your end of the stick.

    As a matter of fact, I've started a Tidal trial (I will probably switch to it anyway) and gapless works perfectly fine with it, as it does with Apple Music. 

    Since you report back on your car system, allow me to note that the Marantz NA6006 streaming device renders gapless playback correctly even with Spotify Connect (which is why my first hypothesis had been that there was an issue with the implementation of it on the Node 2i).

    Well well, hopefully you guys can work it out over Time. The more options for the users the better I guess, particularly as the "implicit" cost of switching streaming service (beyond just Money) might prevent people from adopting your beautifully sounding hardware, which definitely Eclipses the competition!

    Best regards ;)

    Paolo

     

    1
    Comment actions Permalink
  • Avatar
    MarkBrauer

    Has anyone watched the Darko video on gapless playback? It's pretty interesting and explains a lot about the difficulties in implementing gapless.

    https://darko.audio/2019/11/the-battle-for-gapless-playback-with-primare/

    But hasn't Bluesound done gapless for years? The video makes it sound like "conquering" gapless is a new thing.

    0
    Comment actions Permalink
  • Avatar
    Paolo M.

    I did watch it the other day. 

    It's just annoying that I have to be forced in my choice between Tidal and Spotify as I much prefer the latter (sorry, probably just more used to it), and I certainly don't feel like paying for both... 

    I also find it somewhat surprising that gapless works smoothly via Spotify Connect on Marantz and other lower end streaming devices, and not on BlueSound...

     

    0
    Comment actions Permalink
  • Avatar
    MarkBrauer

    Paolo,

    In my experience over the past two years Spotify does play gapless on my Node 2. I just recently "upgraded" to Tidal and can no longer stream Spotify to the Node so I can't test it today. But it was working fine not long ago. If I remember correctly Spotify did have the option of turning gapless on and off. I'd recommend checking Settings in your Spotify account, on BluOS, and on whatever controller app you are using.

    That said, I have read that Spotify is in fact only "almost gapless". That there is actually a very small, hopefully imperceptible, gap. I can say I've only ever heard a gap on Spotify was when having WiFi issues, which is almost never. My favorite test for gapless is Evgeny Kissin playing Beethoven's 32 Variations Wo0 80. The album is available on Spotify. Search for "Beethoven live".

    The piece is recorded on 32 separate tracks, some as short as 11 seconds, that MUST be played gapless. It is an extreme test. I have played this many times on Spotify to demonstrate gapless and never had a problem on my Node 2.

    My understanding is that with BluOS, when playing from network files or Tidal, the buffering necessary for gapless is done in the Bluesound device, and it is done flawlessly. Spotify does not allow BluOS to do this buffering, and Bluesound is only able to reproduce what Spotify is sending. I am guessing that this has to do with Spotify's "Connect" functionally that lets you move seamlessly from device to device and to have multiple devices play in sync. If there was device-level buffering going on in this scenario the whole "Spotify experience" would be upset.

    The take-away here should be the fact that other services are gapless on Bluesound has no bearing on Spotify. They use different means to implement gapless, one controlled by Bluesound and the other by Spotify.

    If, as Tony says, Bluesound has implemented Spotify correctly, I would certainly look at the internet connection to your Bluesound device. If WiFi try Ethernet, or move the Bluesound nearer to the Marantz. Is your WiFi using a "repeater". WIth it's buffering the Bluesound should be almost impervious to an intermittent connection. This would not be as true with Spotify. 

    Good luck getting gapless Spotify working. I know I can't live with gaps. 

    0
    Comment actions Permalink
  • Avatar
    Paolo M.

    Hi MarkBrauer, thanks a lot for all your support and detailed information. 

    I've come back home determined to run some extensive testing based on your feedback, and something strange happened:

    • I launched The Dark Side of The Moon on my Spotify iPhone app (latest version + iOS 13.2) and the album was seamlessly playing with NO gaps (as intended by Pink Floyd) via AirPlay.
    • I then opened the BluOs app to try it from there: went back to track 1 and tried the transition to track 2 = gaps were back (no gapless).
    • I then went back again to the Spotify App and - alas - gaps were also back through it. 

    Note that Spotify plays records (including the Beethoven live you suggested) seamlessly and without any gaps if I just disconnect it from AirPlay and the Node 2i. That to me seems to rule out any issues with:

    1. Spotify itself and its own handling of gapless;
    2. Spotify's settings (the option you're referring to doesn't exist any longer as gapless is now supported as a default);
    3. My wifi connection (I was actually questioning it as a potential source of the buffering issue).

    My impression is that it's the launching of the BluOs app that caused the issue with Spotify Connect, but then again I wasn't able to reproduce this behaviour no matter how may times I've tried. 

    I then tried again the same Beethoven album on Tidal:

    • Gapless works perfectly via the iPhone;
    • Gapless works perfectly via Airplay;
    • Gapless works perfectly via BluOs (iOS app)

    To me, it really looks like the issue lies somewhere in the implementation between the Spotify Connect and BluOs / Node 2i. My tests seem to rule out any other issue, but then again for a short while tonight I had gapless on Spotify via AirPlay, so I am confused and clearly there is a bug somewhere.

    I'd be happy to be proven wrong and find out the solution is really simple and the issue is lying within my settings...

    Hope this helps and would be good to know if anyone is or has been experiencing a similar behaviour. 

    Thanks,

    Paolo

    0
    Comment actions Permalink
  • Avatar
    MarkBrauer

    Paolo,

    Sounds like you've done some solid testing.

    I would also try to isolate Spotify to just the Node 2i.

    I would first shut down all instances of the Spotify app, even those running on a computer or in a browser. Be sure that they are not still running in the background too. Then I'd start up the BluOS controller app on one device, go to the Spotify link in BluOS, and play something requiring gapless.

    The reason I'd do this is that all Spotify apps logged into an account are "Connected" and constantly talk to each other. I could see how Spotify might get confused about device capabilities and stop using gapless. You mention bouncing back and forth between the Spotify app in iOS/Airplay and the one in BluOS and then losing gapless on iOS/Airplay. Running only one instance of Spotify would eliminate the possibility of confusion.

    If you don't get gapless in this isolated situation it would certainly point to a problem with the BluOS/Spotify implementation.

    If you do get gapless in the isolated situation the problem could be some miscommunication between the Spotify apps you have running. This could be a Spotify problem or a BluOS problem.

    I have also used Spotify extensively streaming to a Chromecast Audio device, which is definitely not capable of gapless. Spotify recognizes that I am using this device and stops providing gapless. It is possible that this also disabled gapless on my Node 2 and I just didn't notice it. Something in your environment could be sending a false no-gapless signal to Spotify. This could also be caused by the BluOS/Spotify implementation.

    Again I hope you have luck in figuring this out.

    P.S. I would also say that this is not the best thread for this discussion. I would recommend finding/starting one for just this topic. I would also suggest you find/start one in the Spotify community. There must be others having the same issue and they might never visit this thread..

    0
    Comment actions Permalink
  • Avatar
    Bjørn Ulvik

    Hi,

    I've tested with my setup (Node2i Wired) with the above mentioned album (Evgeny Kissin - Beethoven)

    Windows, Spotify Connect and BluOS is not at all plaing "almost gapless".
    Windows, Spotify and connected amplifier/speakers is playing "gapless".

    Android, Spotify Connect and BluOS App is not at all playing "almost gapless"
    Android app has the setting for "gapless" enabled.

    Windows, BluOS Controller and playing from network share is "gapless"

    0
    Comment actions Permalink
  • Avatar
    MarkBrauer

    Paolo and Bjørn, 

    OK, OK, OK, I think I am figuring this out.

    When I dropped my Spotify Premium subscription last Spring, Spotify was running directly in BluOS as what I'd call a "plugin". Spotify was installed on the Node 2, I logged into Spotify through the BluOS interface, I was presented with a custom Spotify interface, and Spotify then took advantage of all the gapless wonderfulness that Bluesound hardware and BluOS provides. When I dropped Spotify Premium, the link to Spotify disappeared from my BluOS menu and I thought no more about it. 

    Based on some of the descriptions both Paolo and Bjørn gave of their experiences, I thought "something is different here". So I opened up BluOS from my Android controller app, selected Music Services, and then selected Spotify. Instead of installing the Spotify plugin I was familiar with, this took me to the Google Playstore to install the Spotify Android App on my tablet.

    With the Spotify app/plugin not running in the BluOS environment I believe that Spotify, using its generic "Connect" functionality, is now treating the Bluesound device exactly the same as a Chromecast Audio - that is, as a dumb device that is not capable of gapless playback. I cannot confirm this as I am not a Premium subscriber, but your experiences sure point in that direction.

    I suspect that Bluesound has no control over this. Spotify has been forcing hardware suppliers to move away from plugins and to implement Spotify Connect instead. I moved from Squeezebox to Bluesound because Spotify stopped supporting the plugin interface that Squeezebox used. There was no way that Connect support could be added to the then-unsupported Squeezebox. As I said before, Spotify is very serious about supplying the same "experience" across all platforms, and is doing this by supporting access only through Spotify's own apps. And maybe this "experience" no longer includes gapless playback?

    Implementing gapless requires that the streaming software has control of the buffering capabilities of the hardware. Spotify Connect uses the "casting" model, where streaming control is given over to Spotify servers in the cloud - the cloud servers are too "dumb" to interact with the endpoint hardware. When playing through Bluetooth or Airplay, the Spotify app on the controlling device uses the device's buffering capabilities to create a continuous stream which is sent directly to the player, providing a gapless experience. This "mirroring" model for playback of course has other issues.

    If I am correct about all of this I suspect there is little that Bluesound can do to affect Spotify gapless. And if I am correct, it appears Spotify does not care about supporting gapless on all platforms. I hope I am wrong but your only option may be to switch to a music service that does run in BluOS as a fully integrated plugin, like Amazon, Qubuz, and Tidal.

    From my Squeezebox days I remember that Sonos had also used the plugin concept to implement Spotify on their platform and were forced to go to Spotify Connect instead. I wonder if Sonos users have the same issues with gapless?

    I will also point out that Spotify does not partner with Roon, I'm sure for these very same reasons. The Spotify "experience" cannot be successfully commingled with the Roon "experience". https://community.roonlabs.com/t/is-there-a-simple-way-to-stream-spotify-through-roon/54653

    I am sorry if my earlier comments mislead you in any way. I was unaware that the Spotify plugin had been replaced. My suggestions were all based on the way it used to work.

    Again, my advice would be to take this conversation to another thread focusing solely on the Spotify gapless issue. Also, I believe your real gripe is with Spotify, and you should let them know in no uncertain terms that you are not happy with their Connect interface to Bluesound. Or maybe it's time to shop around for another service. Amazon and Qubuz have recently started a "price war" for hi-res streaming.

     

     

     

     

     

     

     

     

    1
    Comment actions Permalink
  • Avatar
    Paolo M.

    Hi Mark,

    What you describe is correct.
    While the Tidal experience happens via the BluOS app, Spotify requires you to download the app and control everything from there via Connect.

    I like Tidal and love its options for high res audio, so I don’t mind switching to it permanently... but the Spotify recommendation and similarity algorithm is just unmatched and I hate to have to miss out on that.

    I agree with your diagnosis but only partially, for two reasons:

    1. The other day, while experimenting I was able to experience gapless playback once or twice.
    2. Marantz streamers use the same Connect experience via the Spotify app + Connect, you aren’t limited to using the HEOS app, and still gapless works perfectly. Why would that be?

    My diagnosis, but actually it is more of a gut feeling and I have no real scientific basis, just empirical tests to say this, is that something is wrong in the way the Bluesound device handles the buffering with Spotify, or in the way the two systems communicate (API integration?). Of course, I might be wrong.

    I have looked it up in the Spotify Community but could not find an existing thread. I will have to start a new one..

    Anyway, overall this is annoying as Node 2i is not exactly a cheap device. Not saying it is Bluesound‘S fault, but I am pretty sure this could be quite easily fixed.

    Perhaps it’s just not a priority?
    But what if someone is so determined to have Spotify to the point of considering switching back to a different streaming device?

    Anyway, shall patiently-ish wait and and see :)

    Thanks a lot for your support.
    Paolo

    0
    Comment actions Permalink
  • Avatar
    MarkBrauer

    Paolo,

    Good info!

    You wrote "Marantz streamers use the same Connect experience via the Spotify app + Connect, you aren’t limited to using the HEOS app, and still gapless works perfectly."

    To me that says that either your API suggestion is at play or... there's no reason that the Connect firmware in the Marantz couldn't have the capability to use the onboard buffering. If either is true, that's good. Maybe Spotify does really care about gapless.

    The question then becomes, why doesn't Bluesound do this?

    You also mention "...I was able to experience gapless playback once or twice." I have had times when I seemed to be experiencing gapless playback on my Chromecast Audio. But then I didn't. I figured that I was just getting a glimpse of the "almost gapless" that some say Spotify is capable of. That's why I like the Kissin/Beethoven as a test. There's no room for "almost" in that piece.

    After 8 or so years with Spotify I switched to Tidal and am not sorry. As an attentive listener using good equipment I always benefit from the higher sound quality. The musical experience is better overall. I should wave switched sooner.

    Being I am no longer a Spotify Premium user, and therefore cannot experiment with any of this stuff, I am going to bow out of this discussion. It has been interesting and I have learned a lot. Thanks for considering my ramblings, hope they helped.

    So, good luck to you and the others in this gapless "dilemma", and I hope you get it resolved. If Spotify ever offers a CD resolution option I would be very tempted to return to them - but only if I could get fully supported gapless on Bluesound.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.