Connecting Node 2 through a network switch

Answered

Comments

23 comments

  • Official comment

    Hi Sripad

    Please review your network switch documentation to ensure that multicast and mDNS traffic is not being blocked. 

    Comment actions Permalink
  • Avatar
    Sripad Sriram

    Thanks - for reference, the switch is a tp-link sg105, which is unmanaged and doesn't provide the ability to filter traffic. I have an Apple TV and receiver connected to the same switch, and I'm able to airplay to both without problems, which probably means multicast traffic is getting through. Any other suggestions you guys might have?

    0
    Comment actions Permalink
  • Hi Sripad

    Please select Help, Send Support request so we can see the log file of the player. You may have to do this while it is wired to the main router for you to see it in the app.

    0
    Comment actions Permalink
  • Avatar
    Sripad Sriram

    Hey there - I opened support request 47972, and the analyst insisted that this was a problem with the switch.

    Again, I find this hard to believe given that I have other devices connected to the same switch that can get to the Internet.

    I did notice a line in the log file that says: 

    Aug 22 03:58:03 (none) user.info ./cp.pl: main::manageConnection ./
    cp.pl (4711) eth0 not connected, attempting wifi connection.
    

    I did have my ethernet cable attached, and I've switching cables, so I'm pretty sure this isn't a problem with the cable.

    Any insights? The support analyst recommended contacting TP-Link, but I'm afraid they're really not going to be able to help given the switch is unmanaged.

     

    0
    Comment actions Permalink
  • Hi Sripad

    Please reply to Support Request 47972, follow the advice by our BluOS Support Crew and continue to work with him.

    If the Bluesound Player is not connecting via wired as you suggest, it is because a connection is not being made.

     

    0
    Comment actions Permalink
  • Avatar
    Frederic D.

    Hello,

    I have the same issue with the Powernode2 connected to the TP link switch TL-SG105. All my other devices connected to the switch are working perfectly and it is not a cable issue. I connected another Bluesound player (Pulse mini) to the switch and same issue. Powernode2 and Pulse mini are not connecting through the switch, however, they are able to connect when connected directly to the router. 

    Please advise me of the support request 47972 corrective action. DO I need to raise a support request? Thanks

    0
    Comment actions Permalink
  • Hi Frederic

    I spoke with the Analyst looking at Sripad's ticket. The issue has to do with the TP-Link switch blocking network traffic by enabling IGMP Snooping and interfering with multicast traffic. Please disable IGMP Snooping in the TP-Link switch.

    0
    Comment actions Permalink
  • Avatar
    Sripad Sriram

    I think the problem is that the tp-link sg105 is an unmanaged switch with no configuration options, so there is no way to disable IGMP.

    0
    Comment actions Permalink
  • Avatar
    Sripad Sriram

    Any response here? As mentioned, the TP-Link SG105 is an unmanaged switch that can't be configured.

    I have an Apple TV connected to the same switch and have no problems using Airplay from my phone to the Apple TV, strongly implying that multicast streams are not being filtered by the switch.

    I'm honestly pretty dissatisfied by the level of support here, particularly given that I'm not the only user have the exact same issue. Can I speak to a manager who can help here?

    0
    Comment actions Permalink
  • Avatar
    Frederic D.

    I ordered a new switch to try it. I hope this will fix the issue, but BluOS communication protocol could be able to deal with unmanaged switches. The goals of an unmanaged switch for the majority of home user is to not have to configure it and block traffic. I was understanding that an unmanaged switch blocks nothing.

    One weird thing, on this post, Bluesound support crew asks to enable the IGMP snooping... https://support.bluesound.com/hc/en-us/community/posts/245380427-Pulse-and-Node-Gen1-constantly-dropping-from-Bluesound-client

    We will see if the new switch solve the issue!

    0
    Comment actions Permalink
  • Avatar
    Frederic D.

    Hi Sripad,

    it works with my new network switch, Netgear GS305

    1
    Comment actions Permalink
  • Avatar
    Bill Carnegie

    I found this post and noticed it was posted last August.....I also experienced the same issue with an unmanaged switch recently...all my other devices connected just fine to the switch........Trying to stream from either my windows home server box or my Qnap NAS was a challenge without experiencing drop outs....the NAS was pretty much unusable while the windows server would only drop out once in awhile .....after doing a lot of trouble shooting and trying the Blue sound tech's suggestions to reboot every device on my network, I figured out that both servers had the same common connection (the switch) after completely changing my network around and getting rid of the switch completely and plugging all the servers and node 2 directly into my router the dropouts completely stopped. Shouldn't this product work with a basic network switch?.......but there's more......now when playing a hi res album I can get through about the first 3-4 tracks and the dropouts return. Usually about a 10-20 seconds of silence, as long as I'm playing a 16 bit 44.100 file no issues. ..I think the larger the file size the harder it is for the node 2 to buffer....this happens with both servers. It couldn't possibly be both servers having problems serving up the same files. By fixing one problem and another surfaces.....judging by the amount of other posts regarding problems with hi res files and or streaming hi res from the net that this is indeed not a true audiophiles device and I'm now second guessing my purchase

    0
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    Hi Bill

    Sounds like you are taking 'simple networking' for granted. Being an audiophile product requires quality networking as we don't use variable bit rate and do not down sample.

    I am escalating your issue to our networking specialists at the Bluesound Support Crew. They can give you some pointers. You also probably want to check out our Networking 101 section; https://support.bluos.net/hc/en-us/sections/360000042348

     

     

    0
    Comment actions Permalink
  • Avatar
    Sripad Sriram

    Just to follow up on what worked for me - I unfortunately had to purchase a new unmanaged switch that didn’t come built in with IGMP snooping, which prevents the Node 2 to use mdns to acquire an IP address. I’d consider this a bug on the Node 2 side since other devices that also use multicast or mdns like Apple TV have no such issues, so something for Bluesounds eng team to consider.

    0
    Comment actions Permalink
  • Avatar
    Bill Carnegie

    I had to upgrade to a managed switch, It appears IGMP snooping in the unmanaged switch was the culprit.  I also had to disable IGMP snooping in my new switch as well as setup port QOS between my NAS and My node 2....I originally had my node 2 setup behind my TV where I really couldn't see it very well.....and when I installed my new switch I moved the node 2 out next to my NAS and switch......now all my 16 bit 44100 flacs still play well with no drop out issues the 24 bit 192 files still cause issues....what I thought was a drop in the stream is actually my node 2 rebooting after about 3 or 4 songs of a hi res album...10 to 20 seconds of the node 2 lit up in red lights. Just like when you ask it to do a reboot or you can get the same response if you load all your files into the play queue and then change songs quickly it will hang and turn red. Doesn't matter which music server I connect it to my NAS or my windows home server... same out come.....and on the topic of simple networking.....most people have this type of network its simple plug and play with zero configuration or the added cost of enterprise gear and the average user wouldn't have any idea what IGMP snooping is, I was only stating that it was a hassle to swap my gear around to accommodate your product and maybe it should just work with whatever network it's plugged into regardless of how much money you throw at your network. 

    0
    Comment actions Permalink
  • Avatar
    Jelmer Brands

    Hi, I just bought the Node 2i and I have the same problem. I can't figure out how to ensure that multicast and mDNS traffic is not being blocked. I use an Ubiquiti EdgeRouter X as a switch. As I understand, it doesn't support IGMP Snooping, so that couldn't be the problem. I have looked for hours but can't find any solution. Can anyone here help me?

    0
    Comment actions Permalink
  • Avatar
    Bill Carnegie

    Found this on the net regarding your edge router and IGMP Snooping.Its a little dated but might get you started in the right direction. I bought a managed switch for my configuration but I didn't buy one that required to much effort to setup. And It seems to work quite well, Hope this helps

    https://community.ui.com/questions/Solved-IGMP-config-help/cfc0dc12-55e3-44dc-862d-14a5c284c876

    0
    Comment actions Permalink
  • Avatar
    Jelmer Brands

    Thanks for your help Bill. I checked the link you gave me, I think I saw it once before. The OP has an EdgeSwitch which has different features (like IGMP snooping) and configuration options than my EdgeRouter X. I found a protocol named IGMP proxy in the configuration tree, which I disabled. It seems to have solved the connection issues. I can't explain why, because I don't know exactly what a IGMP proxy is or does.

    0
    Comment actions Permalink
  • Avatar
    Bill Carnegie

    A switch will, by default, flood multicast traffic to all the ports in a broadcast domain (or the VLAN equivalent). Multicast can cause unnecessary load on host devices by requiring them to process packets they have not solicited. When purposefully exploited, this can form the basis of a denial-of-service attack. IGMP snooping is designed to prevent hosts on a local network from receiving traffic for a multicast group they have not explicitly joined. It provides switches with a mechanism to prune multicast traffic from links that do not contain a multicast listener (an IGMP client).
    Essentially, IGMP snooping is a layer 2 optimization for the layer 3 IGMP. IGMP snooping takes place internally on switches and is not a protocol feature.
    IGMP snooping allows a switch to only forward multicast traffic to the links that have solicited them. Snooping is therefore especially useful for bandwidth-intensive IP multicast applications such as IPTV

    0
    Comment actions Permalink
  • Avatar
    Jelmer Brands

    Thanks for the comprehensive explanation. I hope that by disabling the IGMP Proxy (which is apparently a little different from IGMP Snooping) I didn't cause any other problems. If not, I'll count my blessings.

    0
    Comment actions Permalink
  • Thank you for the feedback gentlemen - I have passed it along to our Quality Assurance Team for future consideration.

    0
    Comment actions Permalink
  • Avatar
    Jelmer Brands

    Tony W. - Product Support Manager Disabling the IGMP proxy did cause some problems with slow internet connections on other devices, so I reverted my changes. Strangely, the connection problems with the Node 2i haven't returned. I am at a loss, but I'm happy it just works for now. I thought maybe you should know.

    1
    Comment actions Permalink
  • Avatar
    Tony W. - Product Support Manager

    IGMP is still not a widely accepted standard so it's implementation we find is a little shaky on some devices according to our Engineering Team. We are working through it though.

    0
    Comment actions Permalink

Please sign in to leave a comment.